Configuring Mikrotik with Tunnelbroker IPV6 Service

[hmtad name=”Adsense Unit 3″ align=”floatright”]
In this tutorial I’m going to show you how to configure Mikrotik Router OS with Hurricane Electric’s Tunnel Broker Service for IPv6 connectivity.

  1. Create an account at www.tunnelbroker.net
  2. Log in and click on create regular tunnel
  3. Type in your WAN IP in IPv4 Endpoint (Your side)
  4. Select the tunnel server nearest to your location
  5. Click create tunnel
  6. They will now provide you with the following details
  7. Now, login to your mikrotik router.

Interface Settings:

/interface ethernet
 set 0 arp=enabled auto-negotiation=yes cable-settings=default
 disable-running-check=yes disabled=no full-duplex=yes mac-address=
 00:0C:29:93:FB:70 mtu=1500 name=WAN speed=100Mbps
 set 1 arp=enabled auto-negotiation=yes cable-settings=default
 disable-running-check=yes disabled=no full-duplex=yes mac-address=
 00:0C:29:93:FB:7A mtu=1500 name=LAN speed=100Mbps
/interface 6to4
 add comment="Hurricane Electric IPv6 Tunnel Broker" disabled=no
 local-address=192.168.0.50 mtu=1280 name=IPV6 remote-address=
 216.218.221.6


IP Address Configurations:

/ip address
add address=192.168.0.50/24 disabled=no interface=WAN network=192.168.0.0
 add address=192.168.41.50/24 disabled=no interface=LAN network=192.168.41.0

 

DNS Configurations:

/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB
 max-udp-packet-size=4096 servers=
 8.8.8.8,8.8.4.4,2001:4860:4860::8844,2001:4860:4860::8888

 

IPv6 Settings:

/ipv6 address
 add address=2001:470:18:1292::2/64 advertise=no disabled=no eui-64=no
 interface=IPV6
 add address=2001:470:19:1292::1/64 advertise=yes disabled=no eui-64=no
 interface=LAN
 /ipv6 nd
 set [ find default=yes ] advertise-dns=yes advertise-mac-address=yes
 disabled=yes hop-limit=unspecified interface=all
 managed-address-configuration=no mtu=unspecified other-configuration=no
 ra-delay=3s ra-interval=5s-30s ra-lifetime=30m reachable-time=unspecified
 retransmit-interval=unspecified
 add advertise-dns=yes advertise-mac-address=yes disabled=no hop-limit=64
 interface=LAN managed-address-configuration=no mtu=unspecified
 other-configuration=no ra-delay=3s ra-interval=5s-30s ra-lifetime=30m
 reachable-time=unspecified retransmit-interval=unspecified
 /ipv6 nd prefix
 add autonomous=no disabled=no interface=LAN on-link=yes preferred-lifetime=1w
 prefix=::/64 valid-lifetime=4w2d
 /ipv6 nd prefix default
 set autonomous=yes preferred-lifetime=4h valid-lifetime=4h
 /ipv6 route
 add disabled=no distance=1 dst-address=::/0 gateway=2001:470:18:1292::1
 scope=30 target-scope=10
 add disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:18:1292::1
 scope=30 target-scope=10

 

Checking IPv6 Connectivity:  

 [admin@MikroTik] > ping 2001:4860:4860::8844
 HOST SIZE TTL TIME STATUS
 2001:4860:4860::8844 56 59 280ms echo reply
 2001:4860:4860::8844 56 59 280ms echo reply
 2001:4860:4860::8844 56 59 280ms echo reply
 2001:4860:4860::8844 56 59 280ms echo reply
 2001:4860:4860::8844 56 59 280ms echo reply
 2001:4860:4860::8844 56 59 280ms echo reply
 2001:4860:4860::8844 56 59 280ms echo reply
 sent=7 received=7 packet-loss=0% min-rtt=280ms avg-rtt=280ms
 max-rtt=280ms

Hooray ! You have now full IPv6 connectivity with the IPv6 world.

 

Enjoyed this post? Share it!